Helpdesk

I recently updated Logic to version X and my D16 plug-in(s) have gone

This article concerns Mac OS X users only

You need to be sure you use the latest versions of D16 plug-ins, since Logic Pro X utilizes 64-Bit architecture exclusively and older versions of our products were available as 32-Bit plug-ins only, which aren't compatible with the latest version of Logic Pro. If that's the case, please log-in to the User Area and grab the latest versions of our plug-ins.

Not suitable solution?

Use the search or contact our staff:

Submit a ticket